নেটওয়ার্কিং বা ইন্টারনেট নেটওয়ার্কিং: মাইক্রোটিক রাউটার কনফিগারেশন(Mikrotik Bangla Tutorial)-07


আসসালামু আলাইকুম। প্রিয় পাঠক। আজকে আমরা কনফিগারেশনে প্রবেশ করবো। প্রথমে VLAN Configuration দেখবো তারপর PPPOE Configuration করবো।

পাঠক নিশ্চয় মনে আছে যে গত পর্বে আমাদেরকে ISP থেকে ৩টি VLAN এবং ৩টি IP Address প্রোভাইড করছেন তা দেয়া আছে। আরও সাথে দিয়েছেন BDIX bgp configuration  এর জন্য AS Number। তো আসুন আমরা কনফিগারেশন দেখি।

প্রথমে ISP থেকে দেয়া ইনফরমেশনগুলো বিস্তারিত দেখবো।

INTERNET INFORMATION:

Internet VLAN: 174

Subnet: 113.239.6.208/30

IP Block: 113.239.6.210/30

Gateway: 113.239.6.209

———————————————————————————————–

YOUTUBR INFORMATION:

Youtube  VLAN: 175

Subnet: 148.119.234.104/30

IP Block: 148.119.234.106/30

Gateway: 148.119.234.105

GGC Peer for Dst. Address: 103.15.144.0/26

—————————————————————————————————

BDIX INFORMATION:

BDIX VLAN: 176

Subnet: 149.115.227.60/30

IP Block: 149.115.227.62/30

Gateway: 149.115.227.61

BDIX BGP Info:

AS= 64330

Remote AS=64477.

এখন আমরা লিন্যাক্সর কমান্ড মোডে কনফিগারেশন  scripts দেখবো। যারা মাইক্রোটিক নিয়ে কাজ করেন মূলত তারা কমান্ড মোডের কনফিগারেশনগুলো সহজে বুঝতে পারবেন। আর যারা নতুন তাদের জন্য থাকবে গ্রাফিক্যাল মোডে সচিত্র কনফিগারেশন। তো আসুন দেখা যাক।

প্রথমে আমরা ইন্টারফেস চয়েস করে নিবো। মানে যে ইন্টারফেসে/পোর্টে আপনার ISP এর লাইনটি লাগানো আছে সেটিকে আমরা ether1-Uplink হিসেবে চিহ্নিত করে নিয়েছি। তার মানে ISP এর লাইনটি লাগানো আছে ১ নাম্বার পোর্টে বা ইন্টারফেসে। আর ২ নাম্বারে পোর্টে বা ইন্টারফেসে আপনার ল্যান সাইডের কনফিগারেশন হবে।

/interface ethernet
set [ find default-name=ether1 ] name=ether1-Uplink
set [ find default-name=ether2 ] name=ether2-LAN

এখন আমাদেরকে  interface  থেকে vlan  এ যেয়ে ISP থেকে দেয়া ৩টি vlan তৈরি করতে হবে। আপনাকে ISP  থেকে  যে vlan নাম্বারগুলো দিয়েছে ঠিক সেইগুলো নাম্বারই দিতে হবে। যদি আলাদা নাম্বার দেন তাহলে কোনও কাজ করবে না। দেখুন নিচের script টি ISP থেকে দেয়া ৩টি vlan এর নাম্বার এবং আমাদের vlan-id নাম্বার একই। তার মানে আমাদের vlan তৈরি ঠিকই আছে। আমরা name=”BDIX VLAN”, “INTERNET VLA “, “YOUTUBE VLAN” দিয়েছি চিনতে সুবিধা হওয়ার জন্য। আপনিও দিতে পারেন। অথবা অন্যকিছু দিতে পারেন নিজের ইচ্ছামত। কোনও সমস্যা হবে না।  আর interface এ আমরা ether1-Uplink দিয়েছি। কারণ আমরা প্রথমেই Uplink/ISP এর জন্য ether1-Uplink চয়েস করে নিয়েছি। আপনাকেও ঠিক একইভাবে চয়েস করে নিতে হবে। মানে আপনার Uplink/ISP এর ফিজিক্যাল লাইনটি যে interface/ পোর্টে লাগানো থাকবে সেটিকে অবশ্যই ইন্টারফেস হিসেবে সেলেক্ট করতে হবে। না হলে কোনও কাজ করবেনা।নিচে দেখুন>>
/interface vlan
add interface=ether1-Uplink  name=”BDIX VLAN” vlan-id=176
add interface=ether1-Uplink  name=”INTERNET VLAN” vlan-id=174
add interface=ether1-Uplink  name=”YOUTUBE VLAN” vlan-id=175

তারপর আমরা ip  থেকে address এ কাজ করবো। এখানে address ঘরে যখন ইন্টারনেট ip(113.239.6.210/30)  দিবেন তখন আপনাকে অবশ্যই interface এ সেলেক্ট করতে হবে INTERNET VLAN কে। মানে আপনি ইন্টারনেট VLAN তৈরি করার সময় যে নাম দিয়েছিলেন সেই নাম। অন্য VLAN সেলেক্ট করলে কোনও কাজ করবে না। অথবা অন্য কোনও ether1,ether2 ………..সেলেক্ট করেন তাও কাজ করবে না। কেননা আপনি VLAN করে কনফিগারেশন করছেন। নিচের কমান্ডগুলো দেখেন।

/ip address
add address=113.239.6.210/30 interface=”INTERNET VLAN” network=113.239.6.208
add address=148.119.234.106/30 interface=”YOUTUBE VLAN” network=148.119.234.104
add address=149.115.227.62/30 interface=”BDIX VLAN” network=149.115.227.60

এখন আমরা ডিএনএস বসানো শিখবো। ডিএনএস আপনাকে আইএসপি থেকে দিয়ে দিবে। আর যদি না দেয় তাহলে গুগলের ওপেন ডিএনএস বসাতে পারেন। ধরুন এখানে আইএসপি থেকে দেয়া ডিএনএস টি হলো: ১০৩.২৩০.৬.৯ আর ওপেন ডিএনএস হলো: ৮.৮.৮.৮

/ip dns
set allow-remote-requests=yes servers=103.230.6.9,8.8.8.8
এখন আমরা রাউট কনফিগারেশন দেখবো। রাউটিং জিনিসটা খুবই গূরুত্বপূর্ণ ইন্টারনেট জগতে। মানে আপনাকে ইন্টারনেটের পথটা তেরি করে দিতে হবে। আর এটি করে রাউটিং।ইন্টারনেটের রাউট কনফিগারেশনে সব সময় মনে রাখবেন যে আপনার আইএসপি থেকে দেয়া আইপিটির গেইটওয়ে বসাতে হবে gateway তে এবং ডেস্টিনেশনে ০.০.০.০/০ রাখবেন। নরমালি ডিফল্ট হিসিবে এটাই থাকে তাই মাথা ঘামানো তেমন লাগবেনা। তবে YOUTUBE এর সময়  অবশ্যই dst-address ০.০.০.০/০ হবে না। আপনাকে আইএসপি  থেকে dst-address এর জন্য একটি ব্লক প্রোভাইড করবে। এখানে আমাদেরকে প্রোভাইড করেছে 103.15.144.0/26  আইপি address টি। নিচে দেখুন আমরা সেটি ইউটুবের গেটওয়ে দেয়ার সময় dst-address হিসেবে দিয়ে দিয়েছি।

/ip route
add distance=1 gateway=45.115.226.5
add distance=1 gateway=149.115.227.61
add distance=1 dst-address=103.15.144.0/26 gateway=148.119.234.105

এরপর আমরা ন্যাটিং করা শিখবো। যেটির মাধ্যমে আমার লোকাল সাইডের ইউজার রা গ্রোবালী কানেকটেড হবে বা পরিচিত হবে। আপনি যতক্ষন পর্যন্ত ন্যাট না করবেন ততক্ষন পর্যন্ত আপনার লোকাল হোস্ট এর কেউ ইন্টারনেট পাবে না। তাই এটি অতীব জরুরী। আপনাকে ৩টি VLAN এর জন্য ৩টি ন্যাট করতে হবে। মানে out-interface হিসেবে একবার INTERNET VLAN, তারপর YOUTUBE VLAN এবং আরেকবার BDIX VLAN সেলেক্ট করতে হবে। দেখুন নিচের কমান্ডগুলো।

/ip firewall nat
add action=masquerade chain=srcnat out-interface=INTERNET VLAN
add action=masquerade chain=srcnat out-interface=YOUTUBE VLAN
add action=masquerade chain=srcnat out-interface=BDIX VLAN

আজকে এই পর্যন্ত। এর পরের টিউটিরিয়ালে গ্রাফিক্যাল মোডে সচিত্র কনফিগারেশন দেখবো। যদি ভাল লাগে তাহলে শেয়ার করবেন আমার সাথে। সামনে আসবে আরও মেগা টিউন মাইক্রোটিক বিষয়ে।
যেকোন্ও যোগাযোগে: tazul.ete12@gmail.com

 

Views All Time
1
Views Today
1
শেয়ার করুন
TwitterFacebookGoogle+

মন্তব্য করুন

মন্তব্য করতে আপনাকে অবশ্যই লগইন করতে হবে