Youtube BW PCQ দিয়ে control করার সহজ পদ্বতি


প্রিয় পাঠক। ধরুন আপনি PPPOE Configure করে আপনার ল্যান সাইডে ইন্টারনেট বের করছেন। আর আপনার ইউজারেরা কেউ 1M, কেউবা 2M, আবার কেউ 3M ইন্টারনেট ব্যান্ডউথ আপনার নিকট থেকে ক্রয় করেছেন। কিন্তু আপনার শর্ত দেয়া আছে যে 1M ইন্টারনেটের সাথে 3M Youtube দিবেন, এরকম 2M ইন্টারনেটের সাথে 5M Youtube দিবেন এবং 3M ইন্টারনেটের সাথে 7M Youtube দিবেন। আপনাকে যে কাজটি করতে হবে তারই টিউটোরিয়াল নিয়ে আজকের আলোচনা। তো আসুন দেখা যাক কেমনে করা যায়।

এখানে আপনাকে কনফিগার করার জন্য Youtube
এর dst-address টা লাগবে। ধরুন dst-addressটা আপনাকে আইএসপি দিয়েছেন= ১৭৫.২৩০.৫.০/২৫। এরকম বড় একটা ব্লক আইএসপি আপনাকে দিয়ে দিবে।

Internet=”300 kb”                        Youtube 1250k

Internet=”512 kb”                        Youtube 1500k

Internet=”750k kb”                      Youtube 1650k

Internet=”1m”                              Youtube 2M

Internet=”1MB2 ”                        Youtube 2500k

Internet=”1MB D party”              Youtube 1500k

Internet=”2MB”                           Youtube 2500k

 

আপনার pool গুলো ধরুন নিচের মত করে কনফিগার করা আছে।

/ip pool
add name=”300 Kb” ranges=192.168.1.2-192.168.1.254
add name=512Kb ranges=192.168.2.2-192.168.2.254
add name=750kb ranges=192.168.3.2-192.168.3.254
add name=1mb ranges=192.168.4.2-192.168.4.254
add name=1MB2 ranges=192.168.5.2-192.168.5.254
add name=”1MB D party” ranges=192.168.6.2-192.168.6.254
add name=”1.5 MB” ranges=192.168.7.2-192.168.7.254
add name=2MB ranges=192.168.8.2-192.168.8.254

এখন আমরা queue type এ কাজ করবো।

/queue type
add kind=pcq name=”1mb down (2000)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=2M  pcq-src-address6-mask=64
add kind=pcq name=”1mb upload (2000)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name=”1MB2 down (2500k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=2500k pcq-src-address6-mask=64
add kind=pcq name=”1MB2 upload (2500k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=2500k pcq-src-address6-mask=64
add kind=pcq name=”1mb d party down (1500k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1M  pcq-src-address6-mask=64
add kind=pcq name=”1mb d party upload (1500k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1500k pcq-src-address6-mask=64
add kind=pcq name=”512k down (1500k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1500k pcq-src-address6-mask=64
add kind=pcq name=”512k upload (1500k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1500k pcq-src-address6-mask=64
add kind=pcq name=”750k down (1650k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1650k pcq-src-address6-mask=64
add kind=pcq name=”750k upload (1500k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1650k pcq-src-address6-mask=64
add kind=pcq name=”300k down (1250k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1250k  pcq-src-address6-mask=64
add kind=pcq name=”300k upload (1250k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1250k pcq-src-address6-mask=64
add kind=pcq name=”2MB down (2500k)” pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=2500k pcq-src-address6-mask=64
add kind=pcq name=”2MB upload (2500k)” pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=2500k pcq-src-address6-mask=64

তারপর কাজ করবো queue simple এ।

/queue simple
add dst=175.230.5.0/25 name=”youtube for 512kb sh” queue=”512k upload (1500k)/512k down (1500k)” target=192.168.2.0/24
add dst=175.230.5.0/25 name=”youtube for 300kb sh” queue=”300k upload (1250k)/300k down (1250k)” target=192.168.1.0/24
add dst=175.230.5.0/25 name=”youtube for 1mb sh” queue=”1mb upload (2000)/1mb down (2000)” target=192.168.4.0/24
add dst=175.230.5.0/25 name=”youtube for 1MB2 sh” queue=”1MB2 upload (2500k)/1MB2 down (2500k)” target=192.168.5.0/24
add dst=175.230.5.0/25 name=”youtube for 2MB sh” queue=”2MB upload (2500k)/2MB down (2500k)” target=192.168.8.0/24
add dst=175.230.5.0/256 name=”youtube for 1mb d parti” queue=”1mb d party upload (1500k)/1mb d party down (1500k)” target=192.168.6.0/24
add dst=175.230.5.0/25 name=”youtube for 750k sh” queue=”750k upload (1500k)/750k down (1650k)” target=192.168.3.0/24

ব্যস হয়ে গেল পুরো কনফিগার। যদি কেউ না বুঝেন তাহলে যোগাযোগ করুন আমার সাথে। যারা মাইক্রোটিক বুঝেন তারা এমনি বুঝবেন। আর যারা নতুন তারা আমার সাথে যোগাযোগ করুন। আল্লাহ হাফেজ।

যেকোনও যোগাযোগে: tazul.ete12@gmail.com

Views All Time
1
Views Today
1
শেয়ার করুন
TwitterFacebookGoogle+

মন্তব্য করুন

মন্তব্য করতে আপনাকে অবশ্যই লগইন করতে হবে